VLAN的概念及实验解析

Windows Windows 2个月前 (08-15) 5次浏览 未收录 0个评论 扫描二维码

VLAN的概念及实验
VLAN(Virtual Local Area Network)的中文名为”虚拟局域网”。
虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。VLAN是一种比较新的技术,工作在OSI参考模型的第2层和第3层,一个VLAN就是一个广播域,VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,VLAN技术更加灵活。
优点: 网络设备的移动、添加和修改的管理开销减少;可以控制广播活动,防止网络风暴;可提高网络的安全性。

基于端口VLAN
静态VLAN ,也称基于端口vlan,是目前最常见的vlan方式:
含义:静态VLAN即明确指定交换机的端口属于那个VLAN,这需要管理员手动配置,当主机连接到交互机端口上时,就被分配到了对应的VLAN中。
基于MAC地址的VLAN
基于MAC地址的VLAN是用终端系统的MAC地址定义的VLAN。MAC地址其实就是指网卡的标识符,每一块网卡的MAC地址都是唯一的。这种方法允许工作站移动到网络的其他物理网段,而自动保持原来的VLAN成员资格。在网络规模较小时,该方案可以说是一个好的方法,但随着网络规模的扩大,网络设备、用户的增加,则会在很大程度上加大管理的难度。
基于路由的VLAN
路由协议工作在7层协议的第3层—网络层,比如基于IP和IPX的路由协议,这类设备包括路由器和路由交换机。在按IP划分的VLAN中,很容易实现路由,即将交换功能和路由功能融合在VLAN交换机中。这种方式既达到了作为VLAN控制广播风暴的最基本目的,又不需要外接路由器。但这种方式对VLAN成员之间的通信速度不是很理想。

Vlan的实验

同个vlan一个网段,实验比较简单,但考虑到当某个部门主机超过254时,就需要一个vlan多个网段,这里设置一个vlan两个网段,规划如图,要求他们都能互通。
VLAN的概念及实验解析

实验规划:
1.所有pc都能通信,四个pc在不同ip,pc1,pc3 为vlan 10,, pc2,pc4为vlan20
2.Pc1 -pc 4 的ip分别为10.2,20.2,30.2,40.2

实验步骤:

sw1的配置,给给个端口配vlan

sw1(config)#vlan 10,20 创建vlan10和vlan20

sw1(config)#int f1/0

sw1(config-if)#switchport mode access

sw1(config-if)#switchport access vlan 10

sw1(config-if)#int f1/1

sw1(config-if)#switchport mode access

sw1(config-if)#switchport access vlan 20

sw1(config-if)#int f1/14 将f1/14端口变成中继口

sw1(config-if)#switchport trunk encapsulation dot1q

sw1(config-if)#switchport mode trunk

2.Sw2的配置,给各个端口配vlan

sw2(config)#vlan 10,20

sw2(config-vlan)#int f1/0

sw2(config-if)#sw

sw2(config-if)#switchport mo

sw2(config-if)#switchport mode a

sw2(config-if)#switchport mode access

sw2(config-if)#sw

sw2(config-if)#switchport a

sw2(config-if)#switchport access vlan 10

sw2(config-if)#int f1/1

sw2(config-if)#sw mo acc

sw2(config-if)#sw acc vlan 20

sw2(config-if)#int f1/13

sw2(config-if)#sw

sw2(config-if)#switchport t

sw2(config-if)#switchport trunk en

sw2(config-if)#switchport trunk encapsulation d

sw2(config-if)#switchport trunk encapsulation dot1q

sw2(config-if)#sw

sw2(config-if)#switchport m

sw2(config-if)#switchport mode t

sw2(config-if)#switchport mode trunk

3.给pc配IP
VLAN的概念及实验解析

4.给路由器做配置。
R3(config)#int range f1/13 -14 给多个端口配置,
R3(config-if-range)#switchport trunk encapsulation dot1q
R3(config-if-range)#switchport mode trunk 将f1/13和f1/14变成中继端口
R3(config)#int vlan 10
R3(config-if)#ip add 192.168.10.1 255.255.255.0 给vlan 10 配IP
R3(config-if)#no shut 开启端口,必须要
R3(config-if)#ip add 192.168.30.1 255.255.255.0 secondary 给vlan 10 配第二个IP
R3(config-if)#no shut
R3(config-if)#int vlan 20
R3(config-if)#ip add 192.168.20.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#ip add 192.168.40.1 255.255.255.0 secondary
R3(config-if)#no shut
R3(config-if)#exit

R3#sh running-config 查看所有端口信息
。。。。。。。
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.30.1 255.255.255.0 secondary
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
ip address 192.168.40.1 255.255.255.0 secondary
ip address 192.168.20.1 255.255.255.0

5.测试
VLAN的概念及实验解析
做一些更改,将vlan 20 添加给端口
R3(config-if-range)#int f1/11
R3(config-if)#switchport mode access
R3(config-if)#switchport access vlan 20
R3(config)#int vlan 20
R3(config-if)#ip add 192.168.20.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#ip add 192.168.40.1 255.255.255.0 se
R3(config-if)#ip add 192.168.40.1 255.255.255.0 secondary
R3(config-if)#no shut
R3#sh ip int b 查看所有端口信息和IP信息
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
FastEthernet0/1 unassigned YES unset administratively down down
FastEthernet1/0 unassigned YES unset up down
FastEthernet1/1 unassigned YES unset up down
FastEthernet1/2 unassigned YES unset up down
FastEthernet1/3 unassigned YES unset up down
FastEthernet1/4 unassigned YES unset up down
FastEthernet1/5 unassigned YES unset up down
再次测试可以了
VLAN的概念及实验解析

总结:这里运用到怎么给vlan添加多个网段,在三层交换机里面,设置vlan的时,需要添加将vlan添加到一个端口,不然会有bug,以及多个端口同时配置命令,怎么设置中继口,怎么设置静态vlan,可以参考脚本文件。

喜欢 (0)
[]
分享 (0)
关于作者:
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址