DHCP中继器的配置-wx5c7fb2b365a40的博客

Windows Windows 2个月前 (08-15) 11次浏览 未收录 0个评论 扫描二维码

这个任务主要是做DHCP中继。
由于DHCP服务器是在路由器上的,而交换机上有三个VLAN,分属于三个不同网段,dhcp的请求报文是广播方式,因此必须在交换机中设置中继才能够传到路由器上。
配置图解:
DHCP中继器的配置-wx5c7fb2b365a40的博客
配置步骤:
1、#配置路由器。

sys
int g0/0
ip address 10.1.1..2 30
quit

#启用DHCP服务。
dhcp enable

#配置dhcp地址池1,为来自 192.168.1.0/24网段内的客户端地址。
命令:

 dhcp server ip-pool 1
 network 192.168.10.0 mask 255.255.255.0
 dns-list 8.8.8.8
 gateway-list 192.168.10.254
 quit

#配置dhcp地址池 2,为来自192.168.20.0/24网段内的客户端分配地址。
命令:

 dhcp server ip-pool 2
 network 192.168.20.0 mask 255.255.255.0
 dns-list 8.8.8.8
 gatewany-list 192.168.20.254
 quit

#配置dhcp地址池 3,为来自192.168.30.0/24网段内的客户端分配地址。
命令:

 dhcp server ip-pool 3
 network 192.168.30.0 mask 255.255.255.0
 dns-list 8.8.8.8
 gatewany-list 192.168.30.254
 quit

#配置静态路由到192.168.0.0/16网段
命令:
ip route-static 192.168.0.0 16 10.1.1.1
2、配置交换机。
#建立VLAN,并配置各个IP接口。
命令:

 system-view
vlan 10
quit
vlan 20
quit
vlan 30
quit

inter range g 1/0/1 to g 1/0/5
port link-type access
port access vlan 10
quit
inter range g 1/0/6 to g 1/0/10
port link-type access
port access vlan 20
quit
inter range g 1/0/11 to g 1/0/15
port link-type access
port access vlan 30
quit

inter vlan 10
ip add 192.168.10.254 24
quit
inter vlan 20
ip add 192.168.20.254 24
quit
inter vlan 30
ip add 192.168.30.254 24
quit

inter g 1/0/23
port link-m r
ip add 10.1.1.1 30
quit

(3)#配置DHCP中继(SWA交换机)
#启用 DHCP 服务。
命令:
dhcp enable

#配置 VLAN 接口 10 工作在 DHCP 中继模式。
命令:

interface vlan-interface 10
dhcp select relay

#配置 DHCP 服务器的地址。
命令:

dhcp relay server-address 10.1.1.2
quit

#配置 VLAN 接口 20 工作在 DHCP 中继模式。
命令:

 interface vlan-interface 20
 dhcp select relay
 dhcp relay server-address 10.1.1.2
 quit

#配置 VLAN 接口 30 工作在 DHCP 中继模式。
命令:

interface vlan-interface 30
dhcp select relay
dhcp relay server-address 10.1.1.2
quit

?著作权归作者所有:来自作者wx5c7fb2b365a40的原创作品,如需转载,请注明出处,否则将追究法律责任

喜欢 (0)
[]
分享 (0)
关于作者:
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址